Mercedes GLA Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi there. I have a GLA 200 cdi (14 plate). Out of the blue the reversing camera has developed a shyness complex. The camera briefly deploys then immediately pops back in its housing, feels guilty, and pops back out again before finally returning ‘in doors’.

Two questions if I may: seemingly rare fault, is it an easy fix (the garage is clueless and wants a fortune to run one of their usually useless diagnostics)? Out of warranty (rare) faults like this - are Mercedes agreeable to meet (some of) the cost as a rule for goodwill purposes?

Appreciate any thoughts.
 

·
Registered
Joined
·
75 Posts
I've not heard anyone mention the issue, I wonder if you can strip the unit down and clean it all out, just to make sure it's nothing simple before paying for them to take a look.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for posting. Seems to be rare, but the car is fixed now. Ironically had l succeeded in accessing the camera, I am confident I could have fixed it! Broken wire. A brown one (rather ironic, I thought).

For a diagnostic, supply and fit it was a shade under £600. Bargain? Maybe not. Fortunately, Mercedes came to the rescue with a goodwill subsidy in the end. Got it down to £200. Still annoying, but not not the end of the world.

Lessons learned:

1) don’t go to a Mercedes independent that offer Mercedes diagnostics unless they have all the other ‘kit’ to fix what they find.

2) don’t accept the ‘cars done a few miles, Sir...’ as justification for the failure of a part that mostly does nothing but sit there.

3) shop around, two Mercedes garages of the same group (15 miles apart) quoted different prices for the same job.

4) take notes and ask to see the part. The camera’s wires are rather thin but one broken wire out of several? Manufacturing issue is my guess.

Cheers,

Baz
 
1 - 3 of 3 Posts
Top